Issues connecting to UserVoice
Incident Report for UserVoice
Postmortem

On Friday, August 11, UserVoice was down and unresponsive from 1:39PM to 1:52PM EDT.

Business Impact

90% of requests failed during the outage. During this time the API, Widget, Admin Console and Web Portal were unresponsive.

  • Admins in the back end of UserVoice would have seen a 503 errors.
  • Users interacting with the web portal would have seen the page hang or a 503 error when performing an action.
  • The UserVoice widget would have been unresponsive and users would not have been able to post ideas or tickets.
  • Our APIs would have given a 500 error.

Root Cause

A key piece of our infrastructure failed, and the fail overs did not take over as expected.

What we are Doing to Prevent This

  • We are updating our infrastructure, which will prevent this type of error from occurring again. You can read more about system update here: https://status.uservoice.com/incidents/rj309y496psw
  • Our engineers have also put a short-term fix in place so we are not at risk of this happening again prior to the update.

You use UserVoice to communicate with your customers, and capture their ideas and feedback around your product. We are sorry for the disruption this caused to you and your teams. If you have any questions, please reach out to me at claire.talbott@uservoice.com.

Claire Talbott

Support Manager

Posted Sep 15, 2017 - 15:07 EDT

Resolved
This incident has been resolved.
Posted Aug 11, 2017 - 14:01 EDT
Investigating
We are seeing errors across portals, admin and API. We are currently investigating.
Posted Aug 11, 2017 - 13:43 EDT