Slowness and Intermittent 504 Errors
Incident Report for UserVoice
Resolved
Slowness and 504 timeouts have subsided since a fix was deployed by CloudFlare.
Posted Nov 21, 2017 - 15:04 EST
Monitoring
We have identified the issue as an issue with CloudFlare. Please refer to CloudFlare's status page for more details: https://www.cloudflarestatus.com/incidents/4c9y56975xg3.

We will continue monitoring application performance and 504's until we confirm a resolution.
Posted Nov 21, 2017 - 14:28 EST
Investigating
We are investigating general slowness and intermittent 504 (Timeout) errors across the application.
Posted Nov 21, 2017 - 13:53 EST