502 errors across UserVoice
Incident Report for UserVoice
Postmortem

On 12/5/17 from 11:10PM to 11:24PM EST, end users and admins may have seen a 502 or 503 error when loading UserVoice, and seen a brief delay in the delivery of emails.

Business Impact

During the incident, end users or admins would have seen a 502 or 503 error page when loading or interacting with the front or back end of a UserVoice site.

API integrations could also have been affected during the incident.

Root Cause

  • We had an issue with our backend server configuration, which caused the outage.

What we are Doing to Prevent This

  • We identified the root issue with our backend servers and resolved.
  • We also have process in place that if the error occurred again, we would be able to address immediately and prevent any customer facing issues.

We understand this interrupted your ability to do your job, and made it difficult for your end users to leave feedback. We are sorry for the pain points this caused for you and your customers.

If you have any questions, please reach out and let me know!

Claire Talbott

Support Manager claire.talbott@uservoice.com

Posted Dec 07, 2017 - 16:13 EST

Resolved
This incident has been resolved.
Posted Dec 05, 2017 - 23:53 EST
Monitoring
We have detected an issue with our backend service-discovery that caused a short-term system outage. Our engineers believe they have corrected the issue, and are monitoring and verifying the system has fully recovered.
Posted Dec 05, 2017 - 23:24 EST
Investigating
We're investigating errors across UserVoice sites and APIs.
Posted Dec 05, 2017 - 23:19 EST