Issue with UserVoice API V2
Incident Report for UserVoice
Postmortem

On 9/11 between 2:15 and 2:50PM EDT, 6% of requests by admins resulted in an error. End users were not impacted by this incident.

Business Impact

Admins could have experienced the following

  • An error message when trying to perform actions like merging ideas or loading a page.
  • Getting logged out unexpectedly

Root Cause

  • Limits we had in place for MySQL connections were insufficient for the high traffic we experienced, so some endpoints and workers were unable to connect to MySQL.

What We are Doing to Prevent This

  • Once identifying the issue, our Systems team raised the limits and put additional backups in place to ensure this issue does not happen again.

We are sorry for the issues you and your admins experienced as a result of this. If you have any questions, please reach out to claire.talbott@uservoice.com.

All the best,

Claire Talbott

Support Manager

Posted Sep 15, 2017 - 15:05 EDT

Resolved
This incident has been resolved.
Posted Sep 11, 2017 - 20:30 EDT
Monitoring
Today we experienced intermittent issues with API v2. This would have impacted customers using V2 of our API, and those loading the suggestions grid in the admin console. End users would not have been affected.

We do have a fix in place, and are monitoring it closely. We will post a post mortem with more details once this is resolved.

We are sorry for the delay in getting our status page updated with the issue, and for how this impacted using our product!
Posted Sep 11, 2017 - 17:13 EDT