DNS Failure Causing Site Availability Issues
Incident Report for UserVoice
Resolved
Cloudflare believes a bad router announcement caused massive backend failures on their system. This caused DNS to fail for multiple regions (explicitly North America). The issue has been fully resolved and tested.
Posted Jul 17, 2020 - 21:12 EDT
Monitoring
CloudFlare appears to have restored service, resolving our downstream issues.
Posted Jul 17, 2020 - 17:47 EDT
Identified
Our DNS and DDoS provider, CloudFlare is having a significant issue right now that is impacting our site availability. We are working with them to try and mitigate/resolve the issue.
Posted Jul 17, 2020 - 17:37 EDT
This incident affected: Web Portal (subdomain), Admin Console, UserVoice API, Helpdesk API, Widgets, Email (incoming), Email (delivery), Search, and User Analytics.