Microsoft365 Email Deliverability

Incident Report for UserVoice

Resolved

This incident has been resolved.
Posted Jan 04, 2024 - 08:49 EST

Investigating

We have received reports and are investigating with Microsoft a higher volume of UserVoice notifications with delayed delivery or being quarantined when the recipient uses Microsoft365 for Email.
Posted Dec 04, 2023 - 21:12 EST
This incident affected: Email (delivery).